Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - ubiquity

Pages: [1]
I am sorry Mirka, my feedback was rather clumsy and I will wait for the changes before providing further feedback on the polyline issues.

It would certainly be good from my point of view if you could find a way to increase the contrast particularly on the white background, or to allow users to vary the contrast to suit their eyesight.
The grid is barely visible for me on the white background from where I sit with my 19.5 inch monitor at arms length even with my prescription spectacles. If I lean forward closer to the monitor then I can see it a little more clearly.

I do certainly appreciate your efforts in developing this software and will continue to explore it from a beginners perspective, which I hope may be helpful.
My background is in end user training and documentation, mainly for desktop software and in particular development of database and spreadsheet applications (Access, Excel, Open Office Base and Calc, VBA etc.) so where I am able I will provide some feedback from that perspective too.

Thanks Mirza,
I have a few extra comments which may be helpful, or a nuisance.
1) When I first choose the Join Polyline button, the command line asks me to:
Select polyline

In my previous comments I suggested that after this command appears and I then click on one of the polylines it becomes selected, even though it does not change to dotted line.
This is not correct - I now notice that when I click on a polyline to select it the properties box shows "Nothing Selected". However the command line assumes that a selection has been made and displays the next command:
Specify other lines/polylines/arcs to join
Thus, although it appears in the command line that the first polyline has been selected and a second or subsequent polyline should now be selected, in fact clicking on a polyline at this point makes the first selection. In other words the command line and selection actions are now out of step.
Once you realise this it is easy but not intuitive to select a subsequent polyline. On the other hand if you don't notice this misstep and assume you have selected both then press enter it is disconcerting to find that one polyline may sometimes disappear never to return.

2) It certainly makes sense to have the objects close to one another to join them in fact I am now finding that it is virtually necessary for 2 polylines to be touching at existing vertices to create a reliable join. I have observed the disappearing polyline phenomenon even when one end of an open polyline (like the W shapes I was creating yesterday) is actually in contact with a non-vertex point of a closed shape like a rectangle (joining these often results in the disappearance of the W shape).

3) I realise that you have said there is a need to fix the joining of straight line segmented polylines and arcs (presumably including ellipses and circles. So this is anecdotal but I found it to be of interest. I tried joining a straight line segmented polyline to a circle. Regardless of the size of the polyline and circle, and their positions, joining them consistently results in them both disappearing and being replaced with a single straight line from the origin to the centre of the circle. This is similar to the phenomenon I observed yesterday where joining a polyline and an arc resulted in the polyline replacing the arc between its two end points.
I guess its related to the algorithm in place to join dissimilar vector paths.

I hope that may have been useful but I will abandon experiments with polyline until your next release.

On an unrelated note. You probably noticed I had changed my background from black to white. I have just noticed that regardless of whether the GRID button is on or off there is no grid for the white background. I choose the white background as it is better for my eyes since I have poor contrast sensitivity (comes partly with old age - I will be 67 soon).

Finally, as BabaCAD is graphical software , it would be useful to me at least, and possibly others, if the ability to attach files to forum posts was turned on for members. Then we could attach screenshots, or even short videos, to support our comments. While I can continue to use linked documents from my Google drive others may not have that capacity

Kind regards,

Hi again,

Earlier today I was attempting to use the Join Polyline from the ribbon interface in BabaCAD 2017.
I am running it on a 64 bit Windows 10 Home machine with integrated Intel graphics.
I found that I was neither able to join two polylines nor a polyline and an arc or spline.
After the first few attempts BabaCAD stopped working, so I first simply re-opened BabaCAD and tried again with the same failed results and a crash.
Following this I shut down my machine and did a reboot too before trying again.
On the next attempt I was unable still to produce joined objects but no further crash took place.
I deleted all objects and began again with my screen recording software running to see if I could reproduce the filed results.
The video file Baba1.mp4 in the following shared folder shows these attempts:

The results are similar to those obtained in previous attempts. When clicking on the Join button on the ribbon after constructing a polyline and an arc the Command Line requests selection of a polyline. If I select the arc first it gives me an error. If I 'select' the polyline first it does not appear selected but the command line asks for selection of another polyline or arc (indicating that the polyline was selected). After then selecting the arc (which is visibly selected) and pressing SPACE or ENTER the result seems to vary randomly between doing nothing, deleting the polyline and replacing the arc with the polyline segments.
I haven't tried a range of segment sizes for the polyline or arc but it does seem to me to be performing erratically, and certainly not as I expected.

Whether anyone else has a similar experience, or can reproduce the issue I don't know.
Hopefully you can give me an explanation or reproduce it yourself.


General discussion about BabaCAD / Links Broken on Website Index Page
« on: July 24, 2017, 04:17:41 pm »

On the home page of the website there are 4 images of things prepared in BabaCAD. The two on the left are fine but the two on the right have links that loop back to the home page and the images are therefore not displayed.



General discussion about BabaCAD / Terminology for Documentation
« on: July 24, 2017, 04:13:36 pm »
Hi Mirza,
I hope I am not being too familiar by using your first name.
On the linked image (see separate link paragraph) I should like to know what your terminology is for the three items indicated.
In v 2.0.0 Errata CommandLine, I think, refers to item 3 as a "Dynamic Input Box". This would seem a convenient description and terminology for it, but it may not be your preferred terminology. My interest here is in perhaps providing some small assistance with documentation as my time allows.

Attempting to post this with an attachment gave me an error regarding the image attachment so I have removed it. Accordingly, here is a link to the image in a Google drive folder I am sharing for the purpose

Also, I am not sure if you prefer to have several issues raised in one post or if each post should address a single topic. Accordingly, for the time being I shall raise separate posts for 2 other issues I have come across.


General discussion about BabaCAD / Re: v 2.0.0 Errata
« on: July 24, 2017, 04:11:36 am »
Re: Q7
While I am more used to using mouse to do many things now I can see how it might be useful to be able to do almost everything from the command line too.
That said, BabaCAD is a wonderful, evolving program and it is great to have such a responsive developer.
LISP is somewhere on my future learning path so I cannot contribute there at the moment but looking at many posts in this forum it seems most of us are interested in the continued development and success of BabaCAD.

General discussion about BabaCAD / Feature Requests
« on: July 22, 2017, 01:08:52 pm »
Are you open to members making requests for features they may have seen/used in other CAD software that might be both useful and perhaps easily implemented?

For example, in DraftSight there are several ways to construct a circle. Three of them can be emulated using circle, arc and ellipse techniques but, so far as I can tell, the remaining two (tangent,tangent,radius) and (tangent,tangent,tangent) cannot be constructed without geometric computation by the person doing the drafting. The (tangent, tangent, tangent) method is very useful to quickly construct inscribed circles precisely within other objects.

Pages: [1]